网络-5 路由重分发下

route-map高级工具

用于3个场景
第一:
1.对于bgp的属性,只能通过route-map修改。
第二:
2.PBR策略路由,工作在路由表之前,工作在数据层面。不影响控制层路由条目的情况下,对数据流量进行选路处理
3.华为中route-policy可以实现PBR功能。policy-base-route可以实现PBR功能这个工具与route-policy一样,但是policy-base-route是专用的选路工具。
第三:
4.路由重分发,将路由进行过滤,引入想要的路由信息。

1.工作机制
1.1 route-map语句,已经匹配立即执行,后面的就不再看了
1.2 permit运行重分发允许路由发布,deny禁止重分发禁止路由进入
1.3 match,可以抓路由下一跳,标记
match ip address x y z 多个访问控制列表,是或逻辑
match ip address a
b
c
逻辑与关系
1.4 使用set进行设置路由条目属性,只有permit放行的路由做set,deny掉的不做,做了也没有任何意义。
1.5 没有match语句,是匹配所有数据

2.distribute-list属于filter-policy过滤
分发列表,permit允许放行与抓取,出向调用表示允许发送,入向调用允许接收。
在分发列表下,扩展ACL不兼容。
DV协议,分发列表特别好用。可以实现更新报文中路由的过滤
LS协议,分发列表不能过滤路由,分发列表只能入向调用进行本地路由抑制,出现调用不生效。由于LS传递的是LSA,LSP。

2.1 distribute用法

网络-5 路由重分发下

R1:
router eigrp 90
network 1.1.1.1 0.0.0.0
network 12.1.1.1 0.0.0.0
network 13.1.1.1 0.0.0.0
distribute-list prefix 2 in Ethernet1/0 或者 distribute-list prefix 2 in 表示所有接口生效
no auto-summary
eigrp router-id 1.1.1.1

ip prefix-list 2 seq 10 deny 2.2.2.2/32
ip prefix-list 2 seq 20 permit 0.0.0.0/0 le 32 前缀没有任何一位需要匹配,掩码是小于等于32表示所有掩码

distribute-list 2 不加prefix就是访问列表

2.2 route-map用法:
R1:
route-map tag permit 10
match ip address prefix-list 2
这里已经把语句过滤,并且放行了其他路由。这个route-map就是加了一个壳,可以不加permit 20但是为了安全,额外加了permit 20
route-map如果这里是抓到了路由,进行了过滤,最后一定要放行所有。
项目中空语句放行所有其他路由必须要加。否则其他路由全部过滤。
set tag 100
route-map tag permit 20

R1# show ip rou 2.2.2.2 路由没有被标记,说明是被第二条语句匹配放行了
Routing entry for 2.2.2.2/32
Known via “eigrp 90”, distance 90, metric 409600, type internal
Redistributing via eigrp 90
Last update from 12.1.1.2 on Et

no route-map tag permit 20
实验中,添加了这个就不能实现2.2.2.2过滤,去掉就可以过滤数据了。
R1(config)#do show ip rou 2.2.2.2
% Network not in table

R1#show ip rou 8.8.8.8 路由被标记了
Routing entry for 8.8.8.8/32
Known via “eigrp 90”, distance 90, metric 409600
Tag 100

2.3 distribute-list gateway工具:
抓取直连邻居的接口地址
可以通过gateway邻居接口地址,进行数据的放行
MA网络中R1接收R2,不接收R3就可以通过这种方式实现
ip prefix R2 se 10 deny 12.1.1.2/32
ip prefix R2 se 100 permit 0.0.0.0/0 le 32
router eigrp 90
distribute-list gateway R2 in

 

网络-5 路由重分发下

2.4 ospf的distribute
R1:
router ospf 100
distribute-list prefix 2 out eigrp 90
可以针对其他协议进行路由过滤
distribute-list prefix 2 out inter s2/0
% Interface not allowed with OUT in case of OSPF
不允许出接口使用分发列表
distribute-list prefix 2 in ethernet 1/0

2.5 distance信息
distance只能使用标准ACL,管理距离与出接口只能本地有效,进行本地修改,对于邻居distance没有影响因为管理距离与出接口不能传递给邻居。他的优势只影响本地。但是度量值的修改影响全局。
第一种方式:
R1:
access-list 10 permit 2.2.2.2
router ospf 100
distance 90 2.2.2.2 0.0.0.0 10
distance <distance> <source-ip><wildcard mask><ACL>
LD协议source-ip要使用源router-id
DV协议source-ip直接使用直连接口地址
第二种方式:
distance ospf intra-area 90 inter-area 100 external 110
intra区域内1类,2类
inter区域间3类
external区域1类外部,2类外部,1类2类的NSSA外部

3.双点双向重分发
ASBR重分发以后,正常情况下只会影响域内路由,ASBR路由信息纹丝不动。
但是ASBR重分发以后,影响到另外一台ASBR路由表,就出现了路由反馈与次优路径。这时候就要将影响之后的路由表调整还原为原ASBR的路由表。
3.1 两个方向的操作,首先顺时针,在逆时针
ASBR1 a重分发进入b以后,将ASBR2的问题解决。ASBR2上再将b重分发回a。
a到b有问题,那么b到a就不会有问题。
ASBR2 a重分发进入b以后,将ASBR1的问题解决。ASBR1上再将b重分发回a。
3.2 重分发以后会有均衡负载的问题,再通过route-map进行路径选择,操控度量值。

R1:
router rip
version 2
no auto-summary
network 12.0.0.0

router ospf 110
router-id 1.1.1.1
network 13.1.1.1 0.0.0.0 area 0

R2:
router rip
version 2
network 2.0.0.0
network 12.0.0.0
network 24.0.0.0
no auto-summary

R3:
router ospf 110
router-id 3.3.3.3
network 13.1.1.3 0.0.0.0 area 0
network 34.1.1.3 0.0.0.0 area 0
network 3.3.3.3 0.0.0.0 area 0

R4:
router rip
version 2
no auto-summary
network 24.0.0.0

router ospf 110
router-id 4.4.4.4
network 34.1.1.4 0.0.0.0 area 0

R1:
router ospf 110
redistribute rip subnets

R4:
show ip route
access-list 10 permit 1.1.1.1
access-list 10 permit 2.2.2.2
access-list 10 permit 12.1.1.0
router ospf 110
distance 150 3.3.3.3 0.0.0.0 10
这里不能写3.3.3.3因为查看路由信息发现链路状态协议的更新源是1.1.1.1
distance 121 1.1.1.1 0.0.0.0 10

R4(config-router)#do show ip rou 2.2.2.2
Routing entry for 2.2.2.2/32
Known via “ospf 110”, distance 110, metric 20, type extern 2, forward metric 74
Last update from 34.1.1.3 on Ethernet1/0, 00:06:36 ago
Routing Descriptor Blocks:
* 34.1.1.3, from 1.1.1.1, 00:06:36 ago, via Ethernet1/0
Route metric is 20, traffic share count is 1

R4(config-router)#do show ip rou 1.1.1.1
Routing entry for 1.1.1.1/32
Known via “ospf 110”, distance 110, metric 20, type extern 2, forward metric 74
Last update from 34.1.1.3 on Ethernet1/0, 00:06:47 ago
Routing Descriptor Blocks:
* 34.1.1.3, from 1.1.1.1, 00:06:47 ago, via Ethernet1/0
Route metric is 20, traffic share count is 1

R4(config-router)#do show ip rou 12.1.1.0
Routing entry for 12.1.1.0/24
Known via “ospf 110”, distance 110, metric 20, type extern 2, forward metric 74
Last update from 34.1.1.3 on Ethernet1/0, 00:06:59 ago
Routing Descriptor Blocks:
* 34.1.1.3, from 1.1.1.1, 00:06:59 ago, via Ethernet1/0
Route metric is 20, traffic share count is 1

再看rip更新的信息,路由恢复正常
R4(config-router)#do show ip rou rip
1.0.0.0/32 is subnetted, 1 subnets
R 1.1.1.1 [120/2] via 24.1.1.2, 00:00:04, Ethernet1/1
2.0.0.0/32 is subnetted, 1 subnets
R 2.2.2.2 [120/1] via 24.1.1.2, 00:00:04, Ethernet1/1
12.0.0.0/24 is subnetted, 1 subnets
R 12.1.1.0 [120/1] via 24.1.1.2, 00:00:04, Ethernet1/1

R4:
router rip
redistribute ospf 110 metric 3

R1(config-router)#do show ip rou ospf
34.0.0.0/24 is subnetted, 1 subnets
O 34.1.1.0 [110/74] via 13.1.1.3, 00:23:25, Serial2/0
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/65] via 13.1.1.3, 00:23:25, Serial2/0
R1(config-router)#do show ip rou rip
2.0.0.0/32 is subnetted, 1 subnets
R 2.2.2.2 [120/1] via 12.1.1.2, 00:00:28, Ethernet1/0
24.0.0.0/24 is subnetted, 1 subnets
R 24.1.1.0 [120/1] via 12.1.1.2, 00:00:28, Ethernet1/0

R4:
router ospf 110
redistribute rip subnets
show ip rou rip

R1(config-router)#do show ip rou rip

R1(config-router)#do show ip rou ospf
34.0.0.0/24 is subnetted, 1 subnets
O 34.1.1.0 [110/74] via 13.1.1.3, 00:27:30, Serial2/0
2.0.0.0/32 is subnetted, 1 subnets
O E2 2.2.2.2 [110/20] via 13.1.1.3, 00:01:09, Serial2/0
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/65] via 13.1.1.3, 00:27:30, Serial2/0
24.0.0.0/24 is subnetted, 1 subnets
O E2 24.1.1.0 [110/20] via 13.1.1.3, 00:01:09, Serial2/0
看到rip域内的路由出现变化为oe2,有问题了

R1:
access-list 10 permit 2.2.2.2
access-list 10 permit 24.1.1.0
方式1修改ospf改大:
router ospf 110
distance 121 4.4.4.4 0.0.0.0 10
方式2:
或者修改rip改小:
router rip
distance 109 12.1.1.2 0.0.0.0 10
R1(config-router)# do show ip rou rip
2.0.0.0/32 is subnetted, 1 subnets
R 2.2.2.2 [109/1] via 12.1.1.2, 00:00:01, Ethernet1/0
24.0.0.0/24 is subnetted, 1 subnets
R 24.1.1.0 [109/1] via 12.1.1.2, 00:00:01, Ethernet1/0
路由恢复正常状态
R1:
router rip
redistribute ospf 110 metric 3

======================================================

R2——————R1——————-R3
G0/0/1——–G0/0/0–G0/0/1———-G0/0/0
2.2.2.2
8.8.8.8

华为rip filter-list
R1:
rip 100
ver 2
undo summary
network 1.0.0.0
network 12.0.0.0
network 13.0.0.0

R2:
rip 100
ver 2
undo summary
network 2.0.0.0
network 12.0.0.0
network 8.0.0.0

R3:
rip 100
ver 2
undo summary
network 3.0.0.0
network 13.0.0.0

基本ACL过滤:
R1:
acl number 2000
rule 10 deny source 2.2.2.2 0.0.0.0
rule 20 permit
rip 100
filter-policy 2000 import gi 0/0/0
show ip routing
R3:
show ip routing

前缀列表过滤:
R1:
ip ip-prefix test index 10 deny 2.2.2.2 32(可以,但是华为官方建议如下)
ip ip-prefix test index 10 deny 2.2.2.2 32 gr 32 le 32
ip ip-prefix test index 10 permit 2.2.2.2 0 le 32
rip 100
undo filter-policy 2000 import gi 0/0/0
filter-policy ip-prefix test import

使用gateway只能用于接受数据的过滤:
如果要使用发送形式的过滤,需要将组播改为单播才能进行发送过滤。
filter-policy gateway ip-prefix test import
R1

华为路由过滤不可以调用route-map,route-policy.思科可以调用route-map
filter-policy acl/ip-prefix
distribute-list acl/ip-prefix/route-map

华为ospf filter-list
R2——————R1——————-R3
G0/0/1——–G0/0/0–G0/0/1———-G0/0/0
2.2.2.2
8.8.8.8

R2:
ospf 10 router-id 2.2.2.2
area 0
network 2.2.2.2 0.0.0.0
network 8.8.8.8 0.0.0.0
network 12.1.1.2 0.0.0.0
R1:
ospf 1 router-id 1.1.1.1
area 0
network 1.1.1.1 0.0.0.0
network 12.1.1.1 0.0.0.0
network 13.1.1.1 0.0.0.0
R3:
ospf 1 router-id 3.3.3.3
area 0
network 3.3.3.3 0.0.0.0
network 13.1.1.3 0.0.0.0

R1:
ospf 1
  filter-policy ip-prefix test export <只能协议>
过滤进入其他协议的路由条目工具,只能用于重分发。
  filter-policy ip-prefix test import
filter-policy 可以使用route-policy/route-map
dis ip routing pro ospf
undo filter-policy ip-prefix test import

route-policy filter-2 permit node 10
  if-match ip-prefix test
ospf 1
  filter-policy route-policy filter-2 import
dis ip routing pro ospf

 

 

 

 

 

======================================================
1.均衡负载导致的路径次优问题,路由优化:

R1(config)#inter s2/0
R1(config-if)#ip ospf cost 10

R3(config-router)#inter s2/1
R3(config-if)#ip ospf cost 10

R1:
ip prefix rip-12 seq 10 permit 12.1.1.0/24
ip prefix ospf-13 seq 10 permit 13.1.1.0/24
ip prefix rip-24 seq 10 permit 24.1.1.0/24
ip prefix ospf-34 seq 10 permit 34.1.1.0/24

route-map o-2-r permit 10
match ip address prefix ospf-13
set metric 2
route-map o-2-r permit 20

router rip
redistribute ospf 110 metric 3 route-map o-2-r

R4:
ip prefix ospf-34 seq 10 permit 34.1.1.0/24
route-map o-2-r permit 10
match ip address prefix ospf-34
set metric 2
route-map o-2-r permit 20

router rip
redistribute ospf 110 metric 3 route-map o-2-r

R1:
ip prefix rip-12 seq 10 permit 12.1.1.0/24
route-map r-2-o permit 10
match ip address prefix rip-12
set metric 18
route-map r-2-o permit 20

router ospf 110
redistribute rip subnets route-map r-2-o

R4:
ip prefix rip-24 seq 10 permit 24.1.1.0/24

route-map r-2-o permit 10
match ip address prefix rip-24
set metric 18
route-map r-2-o permit 20

router ospf 110
redistribute rip subnets route-map r-2-o

2.华为为了避免路由反馈,使用了tag标签做了防环保障

R1 rip路由->ospf 打tag 100

R4 ospf->rip deny tag 100

R4 ospf路由->rip 打tag  300

R1 rip->ospf deny tag 300

———————————–

R1 ospf路由->rip 打tag 200

R4 rip->ospf deny tag 200

R4 rip路由->ospf 打tag 400

R1 rip->ospf deny tag 400

 

原文链接:https://www.cnblogs.com/laohandou/p/16612924.html

原创文章,作者:优速盾-小U,如若转载,请注明出处:https://www.cdnb.net/bbs/archives/17939

(0)
上一篇 2023年2月24日
下一篇 2023年2月25日

相关推荐

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注

优速盾注册领取大礼包www.cdnb.net
/sitemap.xml